通达信火车轨道指标

通达信上下波轨指标,没什么比这个更直接和清楚

您好。此指标用到未来函数,参考使用。

由于代码较多,提示“字数超出最大允许值,请删减!”,将源码以附件上传,请下载参考。效果图如下:


祝投资顺利 。

请大家帮我写一个通达信里面ENE下轨的选股指标

LOWER:=(1-6/100)*MA(CLOSE,25);

ABS(C-LOWER)/LOWER<=0.01;

能把经典火车轨,回头望月,二次握手指标源码给改成通达信的吗?

可以改为通达信的代码如下;

MA10:MA(CLOSE,10);

MA30:MA(CLOSE,30);

MA60:MA(CLOSE,60);

MA5:MA(CLOSE,5),COLORWHITE;

MA20:MA(CLOSE,20),COLORYELLOW;

MA120:MA(C,120),COLORGREEN;

MA250:MA(C,250),COLORMAGENTA;

火车轨:=MA120/REF(MA250,1)>1.03 AND MA120>MA250 AND MA120>REF(MA120,1) AND MA250>REF(MA250,1);

STICKLINE(火车轨,MA120,MA120-0.05,4,0),COLORYELLOW;

STICKLINE(火车轨,MA250,MA250+0.05,4,0),COLORYELLOW;

TT1:=BARSLAST(REF(CROSS(C,MA120),1)) AND CROSS(MA20,MA120);

STICKLINE(TT1,MA120,MA120-0.09,4,0),COLORWHITE;

DRAWTEXT(TT1,MA120-0.13,'回头望月'),COLORWHITE;

FA:=BARSLAST(CROSS(MA10,MA5)) AND CROSS(MA5,MA10);

FB:=FA AND MA5>MA30 AND MA10>MA30 AND MA10>REF(MA10,1);

STICKLINE(FB,LOW,LOW-0.09,4,0),COLORWHITE;

DRAWTEXT(FB,LOW-0.13,'二次握手'),COLORWHITE;

FAX:=BARSLAST(CROSS(MA60,MA20)) AND CROSS(MA20,MA60);

FBX:=FAX AND MA20>MA120 AND MA60>MA120 AND MA20>REF(MA20,1);

STICKLINE(FBX,LOW,LOW-0.09,4,0),COLORWHITE;

DRAWTEXT(FBX,LOW-0.13,'二次握手'),COLOR00FF00;

效果如图

多好的火车轨主图啊,有谁可以把他改成通达信的

M1:=30;
M2:=30;
MA_HIGH:MA(HIGH,30),LINETHICK2;
MA_LOW:MA(LOW,30),LINETHICK2;
STICKLINE(C>=O,C,O,3.4,0),COLOR0000AA;
STICKLINE(C>=O,C,O,3.0,0),COLOR0000BB ;
STICKLINE(C>=O,C,O,2.4,0),COLOR0000CC;
STICKLINE(C>=O,C,O,2.0,0),COLOR0000DD ;
STICKLINE(C>=O,C,O,1.6,0),COLOR0000EE;
STICKLINE(C>=O,C,O,1.2,0),COLOR0000FF;
STICKLINE(C>=O,C,O,0.6,0),COLOR0000FF;
STICKLINE(C>=O,H,L,0,0),COLORRED;
STICKLINE(C<=O,C,O,3.4,0),COLORAAAA00;
STICKLINE(C<=O,C,O,3.0,0),COLORBBBB00;
STICKLINE(C<=O,C,O,2.4,0),COLORCCCC00;
STICKLINE(C<=O,C,O,2.0,0),COLORDDDD00;
STICKLINE(C<=O,C,O,1.6,0),COLOREEEE00;
STICKLINE(C<=O,C,O,1.2,0),COLORFFFF00;
STICKLINE(C<=O,C,O,0.6,0),COLORFFFF00;
STICKLINE(C<=O,H,L,0,0),COLORFFFF00;

通达信捕捉牛股利器 条件选股公式

清仓:=1.66*MA(FORCAST(CLOSE,2),40);
出货:=1.36*MA(FORCAST(CLOSE,2),40);
高抛:=1.16*MA(FORCAST(CLOSE,2),40);
低吸:=0.82*MA(FORCAST(CLOSE,2),40);
满仓:=0.72*MA(FORCAST(CLOSE,2),40);
XG:CROSS(C,满仓) OR CROSS(C,低吸);
{通过测试。{个人看法,仅供参考。}

通达信庄家抓大底公式,好不好自己用着就明白了

DRAWGBK(C>O,RGB(60,0,0),RGB(0,0,0),1,2,1);
VAR1:=(CLOSE-SMA(CLOSE,13,1))/SMA(CLOSE,13,1)*(-100);
VAR2:=REF(VAR1,1)>13 AND REF(VAR1,1)/VAR1>1.23 AND CLOSE/REF(CLOSE,1)>1.03;
感恩庄家:= VAR2 AND REF(CLOSE,1)<=COST(5) AND V>REF(V,1);
牛股:STICKLINE(感恩庄家,0,70,2,0),COLORBLUE,LINETHICK3;
DRAWICON(牛股,73,34);
DRAWTEXT(牛股,59,' 感'),COLOR0000FF;
DRAWTEXT(牛股,43,' 恩'),COLOR0000FF;
DRAWTEXT(牛股,26,' 庄'),COLOR0000FF;
DRAWTEXT(牛股,10,' 家'),COLOR0000FF;